<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8"/>
<meta name="viewport" content="width=device-width"/>
<title>Firefox Front-End Performance Update #14 | Mike Conley&#039;s Blog</title>
<link rel="profile" href="http://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://mikeconley.ca/blog/xmlrpc.php"/>
<!--[if lt IE 9]>
<script src="https://mikeconley.ca/blog/wp-content/themes/twentytwelve/js/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect'/>
<link rel="alternate" type="application/rss+xml" title="Mike Conley&#039;s Blog &raquo; Feed" href="https://mikeconley.ca/blog/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Mike Conley&#039;s Blog &raquo; Comments Feed" href="https://mikeconley.ca/blog/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Mike Conley&#039;s Blog &raquo; Firefox Front-End Performance Update #14 Comments Feed" href="https://mikeconley.ca/blog/2019/03/08/firefox-front-end-performance-update-14/feed/"/>
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mikeconley.ca\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
	<link rel='stylesheet' id='wp-block-library-css' href='https://mikeconley.ca/blog/wp-includes/css/dist/block-library/A.style.min.css,qver=5.1.pagespeed.cf.cOBdefHnvQ.css' type='text/css' media='all'/>
<style id='wp-block-library-theme-css' media='all'>.wp-block-code{padding:.8em 1em;border:1px solid #e2e4e7;border-radius:4px}.wp-block-code,.wp-block-preformatted pre{font-family:Menlo,Consolas,monaco,monospace;font-size:14px;color:#23282d}.wp-block-pullquote{border-top:4px solid #555d66;border-bottom:4px solid #555d66;color:#40464d}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:#40464d;text-transform:uppercase;font-size:13px;font-style:normal}.wp-block-quote{margin:20px 0}.wp-block-quote__citation,.wp-block-quote cite,.wp-block-quote footer{color:#6c7781;font-size:13px;margin-top:1em;position:relative;font-style:normal}.wp-block-quote:not(.is-large):not(.is-style-large){border-left:4px solid #000;padding-left:1em}.wp-block-separator{border:none;border-bottom:2px solid #8f98a1;margin:1.65em auto}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){max-width:100px}.wp-block-table{width:100%;min-width:240px;border-collapse:collapse}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:break-all}</style>
<link rel='stylesheet' id='fancybox-css' href='https://mikeconley.ca/blog/wp-content/plugins/shashin/public/display/fancybox/A.jquery.fancybox.css,qver=1.3.4.pagespeed.cf.pincpDeBkm.css' type='text/css' media='all'/>
<link rel='stylesheet' id='shashinStyle-css' href='https://mikeconley.ca/blog/wp-content/plugins/shashin/public/display/A.shashin.css,qver=3.4.11.pagespeed.cf.HMFdJtxl3j.css' type='text/css' media='all'/>
<link rel='stylesheet' id='twentytwelve-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all'/>
<link rel='stylesheet' id='twentytwelve-style-css' href='https://mikeconley.ca/blog/wp-content/themes/twentytwelve/A.style.css,qver=5.1.pagespeed.cf.xCQmxQyHNC.css' type='text/css' media='all'/>
<link rel='stylesheet' id='twentytwelve-block-style-css' href='https://mikeconley.ca/blog/wp-content/themes/twentytwelve/css/A.blocks.css,qver=20181230.pagespeed.cf.Haste0C-ij.css' type='text/css' media='all'/>
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentytwelve-ie-css'  href='https://mikeconley.ca/blog/wp-content/themes/twentytwelve/css/ie.css?ver=20121010' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css' href='https://mikeconley.ca/blog/wp-content/plugins/jetpack/css/A.jetpack.css,qver=7.0.pagespeed.cf.wPL9J0l1CX.css' type='text/css' media='all'/>
<script type='text/javascript' src='https://mikeconley.ca/blog/wp-includes/js/jquery/jquery.js,qver=1.12.4.pagespeed.jm.pPCPAKkkss.js'></script>
<script src="https://mikeconley.ca/blog/wp-includes,_js,_jquery,_jquery-migrate.min.js,qver==1.4.1+wp-content,_plugins,_shashin,_public,_display,_fancybox,_jquery.fancybox.js,qver==1.3.4.pagespeed.jc.0eVfPaJZht.js"></script><script>eval(mod_pagespeed_Un8QPLDHiw);</script>
<script>eval(mod_pagespeed_wWpVndHopY);</script>
<link rel='https://api.w.org/' href='https://mikeconley.ca/blog/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mikeconley.ca/blog/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mikeconley.ca/blog/wp-includes/wlwmanifest.xml"/> 
<link rel='prev' title='Firefox Front-End Performance Update #13' href='https://mikeconley.ca/blog/2019/02/25/firefox-front-end-performance-update-13/'/>
<meta name="generator" content="WordPress 5.1"/>
<link rel='shortlink' href='https://wp.me/prmTy-Mq'/>
<link rel="alternate" type="application/json+oembed" href="https://mikeconley.ca/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmikeconley.ca%2Fblog%2F2019%2F03%2F08%2Ffirefox-front-end-performance-update-14%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://mikeconley.ca/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmikeconley.ca%2Fblog%2F2019%2F03%2F08%2Ffirefox-front-end-performance-update-14%2F&#038;format=xml"/>
		<script type="text/javascript">var _statcounter=_statcounter||[];_statcounter.push({"tags":{"author":"Mike"}});</script>
		
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
		<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important}</style>
		<link rel="stylesheet" href="https://mikeconley.ca/blog/wp-content/plugins/wp-table-reloaded/css/A.plugin.css,,qver==1.9.4+datatables.css,,qver==1.9.4,Mcc.0oDh0-Xww6.css.pagespeed.cf.aYOAPzqAv3.css" type="text/css" media="all"/>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article"/>
<meta property="og:title" content="Firefox Front-End Performance Update #14"/>
<meta property="og:url" content="https://mikeconley.ca/blog/2019/03/08/firefox-front-end-performance-update-14/"/>
<meta property="og:description" content="We&#8217;re only a few weeks away from Firefox 67 merging from the Nightly channel to Beta, and since my last update, a number of things have landed. It&#8217;s the end of a long week for me, so I …"/>
<meta property="article:published_time" content="2019-03-09T02:27:48+00:00"/>
<meta property="article:modified_time" content="2019-03-09T02:27:52+00:00"/>
<meta property="og:site_name" content="Mike Conley&#039;s Blog"/>
<meta property="og:image" content="https://mikeconley.ca/blog/wp-content/uploads/2019/03/image.png"/>
<meta property="og:image:width" content="2092"/>
<meta property="og:image:height" content="916"/>
<meta property="og:locale" content="en_US"/>
<meta name="twitter:creator" content="@mike_conley"/>
<meta name="twitter:text:title" content="Firefox Front-End Performance Update #14"/>
<meta name="twitter:card" content="summary"/>

<!-- End Jetpack Open Graph Tags -->
			<style type="text/css" id="wp-custom-css">*{hyphens:none}a:visited{color:#5f5f5f!important}</style>
		</head>

<body class="post-template-default single single-post postid-3002 single-format-standard wp-embed-responsive custom-font-enabled">
<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
		<hgroup>
			<h1 class="site-title"><a href="https://mikeconley.ca/blog/" title="Mike Conley&#039;s Blog" rel="home">Mike Conley&#039;s Blog</a></h1>
			<h2 class="site-description">The personal blog of a Toronto based software mechanic, musician, sound designer, and theatre enthusiast.</h2>
		</hgroup>

		<nav id="site-navigation" class="main-navigation" role="navigation">
			<button class="menu-toggle">Menu</button>
			<a class="assistive-text" href="#content" title="Skip to content">Skip to content</a>
			<div class="nav-menu"><ul>
<li><a href="https://mikeconley.ca/blog/">Home</a></li><li class="page_item page-item-2"><a href="https://mikeconley.ca/blog/about/">About</a></li>
<li class="page_item page-item-141"><a href="https://mikeconley.ca/blog/contact/">Contact</a></li>
<li class="page_item page-item-6"><a href="https://mikeconley.ca/blog/cv/">CV</a></li>
<li class="page_item page-item-1884"><a href="https://mikeconley.ca/blog/license/">License</a></li>
</ul></div>
		</nav><!-- #site-navigation -->

			</header><!-- #masthead -->

	<div id="main" class="wrapper">

	<div id="primary" class="site-content">
		<div id="content" role="main">

			
				
	<article id="post-3002" class="post-3002 post type-post status-publish format-standard hentry category-firefox-mozilla-2 category-mozilla-2">
				<header class="entry-header">
			
						<h1 class="entry-title">Firefox Front-End Performance Update #14</h1>
								</header><!-- .entry-header -->

				<div class="entry-content">
			
<p>We&#8217;re only a few weeks away from Firefox 67 merging from the Nightly channel to Beta, and since <a href="https://mikeconley.ca/blog/2019/02/25/firefox-front-end-performance-update-13/">my last update</a>, a number of things have landed.</p>



<p>It&#8217;s the end of a long week for me, so I apologize for the brevity here. Let&#8217;s check it out!</p>



<h2>Document Splitting Foundations for WebRender (In-Progress by Doug Thayer)</h2>



<p>dthayer is still trucking along here &#8211; he&#8217;s ironed out a number of glitches, and kats is giving feedback on some APZ-related changes. dthayer is also working on a WebRender API endpoint for generating frames for multiple documents in a single transaction, which should help reduce the window of opportunity for nasty synchronization bugs.</p>



<h2>Warm-up Service (In-Progress by Doug Thayer)</h2>



<p>dthayer is pressing ahead with this experiment to warm up a number of critical files for Firefox shortly after the OS boots. He is working on a prototype that can be controlled via a pref that we&#8217;ll be able to test on users in a lab-setting (and perhaps in the wild as a SHIELD experiment).</p>



<h2>Startup Cache Telemetry (In-Progress by Doug Thayer)</h2>



<p>dthayer <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1364235">landed this Telemetry early in the week</a>, and data has started to trickle in. After a few more days, it should be easier for us to make inferences on how the startup caches are operating out in the wild for our Nightly users.</p>



<h2>Smoother Tab Animations (In-Progress by Felipe Gomes)</h2>



<p>UX, Product and Engineering are currently hashing out the remainder of the work here. <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1526112">Felipe is also aiming to have the non-responsive tab strip bug fixed soon</a>.</p>



<h2 id="mce_14">Lazier Hidden Window (Completed by Felipe Gomes)</h2>



<p>After a few rounds of landings and backouts, <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=827976">this appears to have stuck</a>! The hidden window is now created after the main window has finished painting, and this has resulted in a nice ts_paint (startup paint) win on our Talos benchmark!</p>



<figure class="wp-block-image"><img data-attachment-id="3003" data-permalink="https://mikeconley.ca/blog/2019/03/08/firefox-front-end-performance-update-14/image/" data-orig-file="https://mikeconley.ca/blog/wp-content/uploads/2019/03/image.png" data-orig-size="2092,916" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image" data-image-description="" data-medium-file="https://mikeconley.ca/blog/wp-content/uploads/2019/03/image.png" data-large-file="https://mikeconley.ca/blog/wp-content/uploads/2019/03/image.png" src="https://mikeconley.ca/blog/wp-content/uploads/2019/03/ximage.png.pagespeed.ic.c4XKbROZ0W.png" alt="" class="wp-image-3003"/><figcaption>This is a graph of the ts_paint startup paint Talos benchmark. The highlighted node is the first mozilla-central build with the hidden window work. Lower is better, so this looks like a nice win!</figcaption></figure>



<p>There&#8217;s still potential for more improvements on the hidden window, but <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1531854">that&#8217;s been split out to a separate project / bug.</a></p>



<h2>Browser Adjustment Project (In-Progress by Gijs Kruitbosch)</h2>



<p>This project appears to be reaching its conclusion, but with rather unsatisfying results. Denis Palmeiro from Vicky Chin&#8217;s team has done a bunch of testing of both the original set of patches that Gijs landed to lower the global frame rate (painting and compositing) from 60fps to 30fps for low-end machines, as well as the new patches that decrease the frequency of main-thread painting (but not compositing) to 30fps. Unfortunately, this has not yielded the page load wins that we wanted<sup id="rf1-3002"><a href="#fn1-3002" title="This was unexpected &ndash; we ran an experiment late in 2018 where we noticed that lowering the frame rate manually via the layout.frame_rate pref had a positive impact on page load time&hellip; unfortunately, this effect is no longer being observed. This might be due to other refresh driver work that has occurred in the meantime." rel="footnote">1</a></sup>. We&#8217;re still waiting to see if there&#8217;s a least a power-usage win here worth pursuing, but we&#8217;re almost ready the pull the plug on this one.</p>



<h2>Better about:newtab Preloading (In-Progress by Gijs Kruitbosch)</h2>



<p><a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1353013">Gijs has a set of patches that should make this possible</a>, which will mean (in theory) that we&#8217;ll present a ready-to-roll about:newtab when users request one more often than not.</p>



<p>Unfortunately, there&#8217;s a small snag with a test failure in automation, <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1353013#c40">but Gijs is on the case</a>.</p>



<h2>Experiments with the Process Priority Manager (In-Progress by Mike Conley)</h2>



<p>The Process Priority Manager has been enabled in Nightly for a number of weeks now, and no new bugs have been filed against it. <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1532767">I filed a bug earlier this week</a> to run a pref-flip experiment on Beta after the Process Priority Manager patches are uplifted later this month. Our hope is that this has a neutral or positive impact on both page load time and user retention!</p>



<h2>Make the PageStyleChild load lazily (Completed by Mike Conley)</h2>



<p><a href="https://developer.mozilla.org/en-US/docs/Web/CSS/Alternative_style_sheets">There&#8217;s an infrequently used feature in Firefox</a> that allows users to switch between different CSS stylesheets that a page might offer. I&#8217;ve made the component that scans the document for alternative stylesheets much lazier, and also made it skip non web-pages, which means (at the very least) less code running when loading about:home and about:newtab</p>



<p><br/></p>
<hr class="footnotes"><ol class="footnotes"><li id="fn1-3002"><p>This was unexpected &#8211; we ran an experiment late in 2018 where we noticed that lowering the frame rate manually via the layout.frame_rate pref had a positive impact on page load time&#8230; unfortunately, this effect is no longer being observed. This might be due to <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1506949">other refresh driver work</a> that has occurred in the meantime.&nbsp;<a href="#rf1-3002" class="backlink" title="Jump back to footnote 1 in the text.">&#8617;</a></p></li></ol>					</div><!-- .entry-content -->
		
		<footer class="entry-meta">
			This entry was posted in <a href="https://mikeconley.ca/blog/category/mozilla-2/firefox-mozilla-2/" rel="category tag">Firefox</a>, <a href="https://mikeconley.ca/blog/category/mozilla-2/" rel="category tag">Mozilla</a> on <a href="https://mikeconley.ca/blog/2019/03/08/firefox-front-end-performance-update-14/" title="9:27 pm" rel="bookmark"><time class="entry-date" datetime="2019-03-08T21:27:48-05:00">March 8, 2019</time></a><span class="by-author"> by <span class="author vcard"><a class="url fn n" href="https://mikeconley.ca/blog/author/admin/" title="View all posts by Mike" rel="author">Mike</a></span></span>.								</footer><!-- .entry-meta -->
	</article><!-- #post -->

				<nav class="nav-single">
					<h3 class="assistive-text">Post navigation</h3>
					<span class="nav-previous"><a href="https://mikeconley.ca/blog/2019/02/25/firefox-front-end-performance-update-13/" rel="prev"><span class="meta-nav">&larr;</span> Firefox Front-End Performance Update #13</a></span>
					<span class="nav-next"></span>
				</nav><!-- .nav-single -->

				
<div id="comments" class="comments-area">

	
	
	
</div><!-- #comments .comments-area -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


			<div id="secondary" class="widget-area" role="complementary">
			<aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://mikeconley.ca/blog/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s"/>
					<input type="submit" id="searchsubmit" value="Search"/>
				</div>
			</form></aside><aside id="shashinwidgetwp-3" class="widget "><h3 class="widget-title">Three Photos</h3><div class="shashinPhotoGroups"><div class="shashinThumbnailsTable" id="shashinGroup_1_1" style="margin-left: auto; margin-right: auto;clear: none;">
<div class="shashinCaption"></div>
<div class="shashinTableRow">
<div class="shashinTableCell" data-original_width="100%" style=" width: 100%; max-width: 150px;"><div class="shashinThumbnailWrapper"><a href="https://lh3.googleusercontent.com/-mpQvTFwu_F4/SkvNKNKtKkI/AAAAAAAAAoA/hAaABtvdOw4/DSCF2898.jpg?imgmax=800" id="shashinThumbnailLink_1" data-ShashinPhoto="536" class="shashinFancybox" rel="shashinFancybox_1"><img src="https://lh3.googleusercontent.com/-mpQvTFwu_F4/SkvNKNKtKkI/AAAAAAAAAoA/hAaABtvdOw4/DSCF2898.jpg?imgmax=150&amp;crop=1" alt="" width="150" class="shashinThumbnailImage" id="shashinThumbnailImage_1"/></a><div class="shashinFancyboxCaptionWrapper" id="shashinFancyboxCaption_1">
<div class="shashinFancyboxCaption">
<div class="shashinFancyboxCaptionClose"><a href="#" onclick="jQuery.fancybox.close();"><img alt="Close" src="https://mikeconley.ca/blog/wp-content/plugins/shashin/public/display/fancybox/xcloselabel.gif.pagespeed.ic.PjE2kn_zUh.png"/></a></div>
<strong><span class="shashinCaptionExif">26-Jun-2009 08:28, FUJIFILM FinePix A345, 2.8, 5.8mm, 0.004 sec, ISO 64</span></strong><div class="shashinLinkToOriginalPhoto"><a href="https://picasaweb.google.com/102046754196003513928/PolandTrip2#5353598157276916290">View at Picasa</a></div>
<!-- comment for image counter --></div>
</div>

</div></div>
</div><div class="shashinTableRowClear">&nbsp;</div>
<div class="shashinTableRow">
<div class="shashinTableCell" data-original_width="100%" style=" width: 100%; max-width: 150px;"><div class="shashinThumbnailWrapper"><a href="https://lh3.googleusercontent.com/-FSDgsmBIWHE/SkuqLpt2xuI/AAAAAAAAAek/IsYhXD_Jecg/DSCF2758.jpg?imgmax=800" id="shashinThumbnailLink_2" data-ShashinPhoto="402" class="shashinFancybox" rel="shashinFancybox_1" title="I think this is Krakow University"><img src="https://lh3.googleusercontent.com/-FSDgsmBIWHE/SkuqLpt2xuI/AAAAAAAAAek/IsYhXD_Jecg/DSCF2758.jpg?imgmax=150&amp;crop=1" alt="I think this is Krakow University" width="150" class="shashinThumbnailImage" id="shashinThumbnailImage_2"/></a><div class="shashinFancyboxCaptionWrapper" id="shashinFancyboxCaption_2">
<div class="shashinFancyboxCaption">
<div class="shashinFancyboxCaptionClose"><a href="#" onclick="jQuery.fancybox.close();"><img alt="Close" src="https://mikeconley.ca/blog/wp-content/plugins/shashin/public/display/fancybox/xcloselabel.gif.pagespeed.ic.PjE2kn_zUh.png"/></a></div>
<strong>I think this is Krakow University<span class="shashinCaptionExif">23-Jun-2009 08:38, FUJIFILM FinePix A345, 2.81, 5.8mm, 0.012 sec, ISO 64</span></strong><div class="shashinLinkToOriginalPhoto"><a href="https://picasaweb.google.com/102046754196003513928/PolandTrip1#5353559699213436642">View at Picasa</a></div>
<!-- comment for image counter --></div>
</div>

</div></div>
</div><div class="shashinTableRowClear">&nbsp;</div>
<div class="shashinTableRow">
<div class="shashinTableCell" data-original_width="100%" style=" width: 100%; max-width: 150px;"><div class="shashinThumbnailWrapper"><a href="https://lh3.googleusercontent.com/-bwlFV9Y2cDA/Skuc0BsN72I/AAAAAAAAAFI/7hJ7bsQ0ckY/DSCF2319.jpg?imgmax=800" id="shashinThumbnailLink_3" data-ShashinPhoto="39" class="shashinFancybox" rel="shashinFancybox_1"><img src="https://lh3.googleusercontent.com/-bwlFV9Y2cDA/Skuc0BsN72I/AAAAAAAAAFI/7hJ7bsQ0ckY/DSCF2319.jpg?imgmax=150&amp;crop=1" alt="" width="150" class="shashinThumbnailImage" id="shashinThumbnailImage_3"/></a><div class="shashinFancyboxCaptionWrapper" id="shashinFancyboxCaption_3">
<div class="shashinFancyboxCaption">
<div class="shashinFancyboxCaptionClose"><a href="#" onclick="jQuery.fancybox.close();"><img alt="Close" src="https://mikeconley.ca/blog/wp-content/plugins/shashin/public/display/fancybox/xcloselabel.gif.pagespeed.ic.PjE2kn_zUh.png"/></a></div>
<strong><span class="shashinCaptionExif">16-Jun-2009 01:40, FUJIFILM FinePix A345, 4.71, 5.8mm, 0.003 sec, ISO 64</span></strong><div class="shashinLinkToOriginalPhoto"><a href="https://picasaweb.google.com/102046754196003513928/PolandTrip1#5353544999680995170">View at Picasa</a></div>
<!-- comment for image counter --></div>
</div>

</div></div>
</div><div class="shashinTableRowClear">&nbsp;</div>
<div class="shashinCaptionBottom shashinCaption"></div>
</div>
</div>
</aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title">NOTICE</h3>			<div class="textwidget"><p>Persons attempting to find a motive in this narrative will be prosecuted; persons attempting to find a moral in it will be banished; persons attempting to find a plot in it will be shot.</p>
<p>By order of the author,<br/>
Per G. G., Chief of Ordinance</p>
</div>
		</aside><aside id="categories-358727651" class="widget widget_categories"><h3 class="widget-title">Categories</h3>		<ul>
				<li class="cat-item cat-item-428"><a href="https://mikeconley.ca/blog/category/personal/adventure-games/">Adventure Games</a>
</li>
	<li class="cat-item cat-item-380"><a href="https://mikeconley.ca/blog/category/technology/firefox-extensions/alertcheck-firefox-extensions-technology/">alertCheck</a>
</li>
	<li class="cat-item cat-item-454"><a href="https://mikeconley.ca/blog/category/technology/computer-science/code-reviews/">Code Reviews</a>
</li>
	<li class="cat-item cat-item-168"><a href="https://mikeconley.ca/blog/category/personal/comedy-personal/">Comedy</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://mikeconley.ca/blog/category/technology/computer-science/">Computer Science</a>
</li>
	<li class="cat-item cat-item-615"><a href="https://mikeconley.ca/blog/category/technology/computer-science/courses-computer-science-technology/">Courses</a>
</li>
	<li class="cat-item cat-item-1032"><a href="https://mikeconley.ca/blog/category/mozilla-2/thunderbird/ensemble-thunderbird/">Ensemble</a>
</li>
	<li class="cat-item cat-item-657"><a href="https://mikeconley.ca/blog/category/technology/computer-science/code-reviews/review-board/extensions-review-board-code-reviews-computer-science-technology/">Extensions</a>
</li>
	<li class="cat-item cat-item-874"><a href="https://mikeconley.ca/blog/category/mozilla-2/firefox-mozilla-2/">Firefox</a>
</li>
	<li class="cat-item cat-item-220"><a href="https://mikeconley.ca/blog/category/technology/firefox-extensions/">Firefox Extensions</a>
</li>
	<li class="cat-item cat-item-773"><a href="https://mikeconley.ca/blog/category/technology/computer-science/gsoc-computer-science/">GSoC</a>
</li>
	<li class="cat-item cat-item-44"><a href="https://mikeconley.ca/blog/category/technology/internet/">Internet</a>
</li>
	<li class="cat-item cat-item-68"><a href="https://mikeconley.ca/blog/category/technology/javascript/">Javascript</a>
</li>
	<li class="cat-item cat-item-1117"><a href="https://mikeconley.ca/blog/category/technology/livecoding/">Livecoding</a>
</li>
	<li class="cat-item cat-item-861"><a href="https://mikeconley.ca/blog/category/mozilla-2/">Mozilla</a>
</li>
	<li class="cat-item cat-item-951"><a href="https://mikeconley.ca/blog/category/sound/music-sound/">Music</a>
</li>
	<li class="cat-item cat-item-110"><a href="https://mikeconley.ca/blog/category/musings/">Musings</a>
</li>
	<li class="cat-item cat-item-238"><a href="https://mikeconley.ca/blog/category/personal/operation-party-mansion-personal/">Operation: Party Mansion</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://mikeconley.ca/blog/category/personal/">Personal</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://mikeconley.ca/blog/category/technology/php/">PHP</a>
</li>
	<li class="cat-item cat-item-273"><a href="https://mikeconley.ca/blog/category/personal/poland/">Poland</a>
</li>
	<li class="cat-item cat-item-626"><a href="https://mikeconley.ca/blog/category/technology/computer-science/research-computer-science-technology/">Research</a>
</li>
	<li class="cat-item cat-item-649"><a href="https://mikeconley.ca/blog/category/technology/computer-science/code-reviews/review-board/">Review Board</a>
</li>
	<li class="cat-item cat-item-162"><a href="https://mikeconley.ca/blog/category/technology/ruby-on-rails-technology/">Ruby on Rails</a>
</li>
	<li class="cat-item cat-item-51"><a href="https://mikeconley.ca/blog/category/technology/security/">Security</a>
</li>
	<li class="cat-item cat-item-115"><a href="https://mikeconley.ca/blog/category/sound/">Sound</a>
</li>
	<li class="cat-item cat-item-79"><a href="https://mikeconley.ca/blog/category/technology/">Technology</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://mikeconley.ca/blog/category/theater/">Theater</a>
</li>
	<li class="cat-item cat-item-862"><a href="https://mikeconley.ca/blog/category/mozilla-2/thunderbird/">Thunderbird</a>
</li>
	<li class="cat-item cat-item-899"><a href="https://mikeconley.ca/blog/category/personal/traveling/">Traveling</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://mikeconley.ca/blog/category/ucdp/">UCDP</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://mikeconley.ca/blog/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			</aside><aside id="twitter-1" class="widget widget_twitter"><h3 class="widget-title"><a href="http://twitter.com/mike_conley" class="twitter_title_link">My Tweets on Twitter</a></h3><ul class="twitter"><li>No public Twitter messages.</li></ul></aside><aside id="recent-comments-2" class="widget widget_recent_comments"><h3 class="widget-title">Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://www.ghacks.net/2018/01/12/firefox-tab-warming-explained/' rel='external nofollow' class='url'>Firefox Tab Warming explained - gHacks Tech News</a></span> on <a href="https://mikeconley.ca/blog/2018/01/11/making-tab-switching-faster-in-firefox-with-tab-warming/comment-page-1/#comment-438908">Making tab switching faster in Firefox with tab warming</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://placeholderapi.wordpress.com/2018/01/12/mozilla-firefox-technique-we-used-to-make-tab-closing-faster-ht/' rel='external nofollow' class='url'>#mozilla #firefox &#8220;technique we used to make tab closing faster&#8221; ht&#8230; | Dr. Roy Schestowitz (罗伊)</a></span> on <a href="https://mikeconley.ca/blog/2018/01/11/making-tab-switching-faster-in-firefox-with-tab-warming/comment-page-1/#comment-438907">Making tab switching faster in Firefox with tab warming</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://clusterassets.wordpress.com/2018/01/12/new-top-story-on-hacker-news-making-tab-switching-faster-in-firefox-with-tab-warming/' rel='external nofollow' class='url'>New top story on Hacker News: Making tab switching faster in Firefox with tab warming &#8211; ÇlusterAssets Inc.,</a></span> on <a href="https://mikeconley.ca/blog/2018/01/11/making-tab-switching-faster-in-firefox-with-tab-warming/comment-page-1/#comment-438906">Making tab switching faster in Firefox with tab warming</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.startupon.net/2018/01/12/making-tab-switching-sooner-in-firefox-with-tab-warming/' rel='external nofollow' class='url'>Making tab switching sooner in Firefox with tab warming &#8211; Startupon.net</a></span> on <a href="https://mikeconley.ca/blog/2018/01/11/making-tab-switching-faster-in-firefox-with-tab-warming/comment-page-1/#comment-438905">Making tab switching faster in Firefox with tab warming</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://slidermusic.de/video=1131780/' rel='external nofollow' class='url'>Making tab switching faster in Firefox with tab warming</a></span> on <a href="https://mikeconley.ca/blog/2018/01/11/making-tab-switching-faster-in-firefox-with-tab-warming/comment-page-1/#comment-438904">Making tab switching faster in Firefox with tab warming</a></li></ul></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
											<li>
					<a href="https://mikeconley.ca/blog/2019/03/08/firefox-front-end-performance-update-14/">Firefox Front-End Performance Update #14</a>
									</li>
											<li>
					<a href="https://mikeconley.ca/blog/2019/02/25/firefox-front-end-performance-update-13/">Firefox Front-End Performance Update #13</a>
									</li>
											<li>
					<a href="https://mikeconley.ca/blog/2019/02/06/firefox-front-end-performance-update-12/">Firefox Front-End Performance Update #12</a>
									</li>
											<li>
					<a href="https://mikeconley.ca/blog/2018/09/20/firefox-performance-update-11/">Firefox Performance Update #11</a>
									</li>
											<li>
					<a href="https://mikeconley.ca/blog/2018/07/24/firefox-performance-update-10/">Firefox Performance Update #10</a>
									</li>
					</ul>
		</aside><aside id="tag_cloud-2" class="widget widget_tag_cloud"><h3 class="widget-title">Tags</h3><div class="tagcloud"><ul class='wp-tag-cloud' role='list'>
	<li><a href="https://mikeconley.ca/blog/tag/address-book/" class="tag-cloud-link tag-link-934 tag-link-position-1" style="font-size: 13.779816513761pt;" aria-label="address book (19 items)">address book</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/alert/" class="tag-cloud-link tag-link-207 tag-link-position-2" style="font-size: 8.6422018348624pt;" aria-label="alert (7 items)">alert</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/alertcheck/" class="tag-cloud-link tag-link-210 tag-link-position-3" style="font-size: 8pt;" aria-label="alertCheck (6 items)">alertCheck</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/australis/" class="tag-cloud-link tag-link-1041 tag-link-position-4" style="font-size: 8.6422018348624pt;" aria-label="australis (7 items)">australis</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/cocoa/" class="tag-cloud-link tag-link-1137 tag-link-position-5" style="font-size: 8pt;" aria-label="cocoa (6 items)">cocoa</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/code-review/" class="tag-cloud-link tag-link-501 tag-link-position-6" style="font-size: 17.247706422018pt;" aria-label="code review (36 items)">code review</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/code-reviews/" class="tag-cloud-link tag-link-1218 tag-link-position-7" style="font-size: 10.954128440367pt;" aria-label="Code Reviews (11 items)">Code Reviews</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/computer-science/" class="tag-cloud-link tag-link-1205 tag-link-position-8" style="font-size: 8.6422018348624pt;" aria-label="Computer Science (7 items)">Computer Science</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/contacts/" class="tag-cloud-link tag-link-935 tag-link-position-9" style="font-size: 13.522935779817pt;" aria-label="contacts (18 items)">contacts</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/cpow/" class="tag-cloud-link tag-link-1108 tag-link-position-10" style="font-size: 11.339449541284pt;" aria-label="cpow (12 items)">cpow</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/drama/" class="tag-cloud-link tag-link-17 tag-link-position-11" style="font-size: 10.954128440367pt;" aria-label="drama (11 items)">drama</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/e10s/" class="tag-cloud-link tag-link-1069 tag-link-position-12" style="font-size: 14.550458715596pt;" aria-label="e10s (22 items)">e10s</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/education/" class="tag-cloud-link tag-link-58 tag-link-position-13" style="font-size: 8.6422018348624pt;" aria-label="education (7 items)">education</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/electrolysis/" class="tag-cloud-link tag-link-1068 tag-link-position-14" style="font-size: 9.2844036697248pt;" aria-label="electrolysis (8 items)">electrolysis</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/ensemble/" class="tag-cloud-link tag-link-96 tag-link-position-15" style="font-size: 8pt;" aria-label="ensemble (6 items)">ensemble</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/experiment/" class="tag-cloud-link tag-link-496 tag-link-position-16" style="font-size: 8.6422018348624pt;" aria-label="experiment (7 items)">experiment</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/extension/" class="tag-cloud-link tag-link-213 tag-link-position-17" style="font-size: 9.9266055045872pt;" aria-label="extension (9 items)">extension</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/extensions/" class="tag-cloud-link tag-link-131 tag-link-position-18" style="font-size: 10.440366972477pt;" aria-label="extensions (10 items)">extensions</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/firefox/" class="tag-cloud-link tag-link-125 tag-link-position-19" style="font-size: 20.073394495413pt;" aria-label="firefox (61 items)">firefox</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/gecko/" class="tag-cloud-link tag-link-1018 tag-link-position-20" style="font-size: 8.6422018348624pt;" aria-label="gecko (7 items)">gecko</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/grad-school/" class="tag-cloud-link tag-link-177 tag-link-position-21" style="font-size: 9.2844036697248pt;" aria-label="grad school (8 items)">grad school</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/gsoc/" class="tag-cloud-link tag-link-92 tag-link-position-22" style="font-size: 8pt;" aria-label="gsoc (6 items)">gsoc</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/hostel/" class="tag-cloud-link tag-link-286 tag-link-position-23" style="font-size: 8pt;" aria-label="hostel (6 items)">hostel</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/javascript/" class="tag-cloud-link tag-link-1212 tag-link-position-24" style="font-size: 11.853211009174pt;" aria-label="Javascript (13 items)">Javascript</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/livehacking/" class="tag-cloud-link tag-link-1103 tag-link-position-25" style="font-size: 14.550458715596pt;" aria-label="livehacking (22 items)">livehacking</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/markus/" class="tag-cloud-link tag-link-550 tag-link-position-26" style="font-size: 9.9266055045872pt;" aria-label="MarkUs (9 items)">MarkUs</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/mozilla/" class="tag-cloud-link tag-link-35 tag-link-position-27" style="font-size: 22pt;" aria-label="mozilla (87 items)">mozilla</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/mozilla-messaging/" class="tag-cloud-link tag-link-877 tag-link-position-28" style="font-size: 8.6422018348624pt;" aria-label="mozilla messaging (7 items)">mozilla messaging</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/olm/" class="tag-cloud-link tag-link-84 tag-link-position-29" style="font-size: 8pt;" aria-label="olm (6 items)">olm</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/peer-review/" class="tag-cloud-link tag-link-494 tag-link-position-30" style="font-size: 8pt;" aria-label="peer review (6 items)">peer review</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/performance/" class="tag-cloud-link tag-link-1044 tag-link-position-31" style="font-size: 12.238532110092pt;" aria-label="performance (14 items)">performance</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/poland/" class="tag-cloud-link tag-link-1216 tag-link-position-32" style="font-size: 13.779816513761pt;" aria-label="Poland (19 items)">Poland</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/printing/" class="tag-cloud-link tag-link-1107 tag-link-position-33" style="font-size: 9.2844036697248pt;" aria-label="printing (8 items)">printing</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/research/" class="tag-cloud-link tag-link-503 tag-link-position-34" style="font-size: 11.339449541284pt;" aria-label="research (12 items)">research</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/review-board/" class="tag-cloud-link tag-link-1219 tag-link-position-35" style="font-size: 13.266055045872pt;" aria-label="Review Board (17 items)">Review Board</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/reviewboard/" class="tag-cloud-link tag-link-504 tag-link-position-36" style="font-size: 14.293577981651pt;" aria-label="reviewboard (21 items)">reviewboard</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/security/" class="tag-cloud-link tag-link-1211 tag-link-position-37" style="font-size: 8pt;" aria-label="Security (6 items)">Security</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/statistics/" class="tag-cloud-link tag-link-635 tag-link-position-38" style="font-size: 8.6422018348624pt;" aria-label="statistics (7 items)">statistics</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/theater/" class="tag-cloud-link tag-link-1208 tag-link-position-39" style="font-size: 9.9266055045872pt;" aria-label="Theater (9 items)">Theater</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/thunderbird-2/" class="tag-cloud-link tag-link-867 tag-link-position-40" style="font-size: 16.733944954128pt;" aria-label="thunderbird (33 items)">thunderbird</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/ubuntu/" class="tag-cloud-link tag-link-705 tag-link-position-41" style="font-size: 8.6422018348624pt;" aria-label="ubuntu (7 items)">ubuntu</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/ucdp/" class="tag-cloud-link tag-link-1204 tag-link-position-42" style="font-size: 13.522935779817pt;" aria-label="UCDP (18 items)">UCDP</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/uoft/" class="tag-cloud-link tag-link-67 tag-link-position-43" style="font-size: 10.954128440367pt;" aria-label="uoft (11 items)">uoft</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/warsaw/" class="tag-cloud-link tag-link-275 tag-link-position-44" style="font-size: 8pt;" aria-label="warsaw (6 items)">warsaw</a></li>
	<li><a href="https://mikeconley.ca/blog/tag/wroclaw/" class="tag-cloud-link tag-link-277 tag-link-position-45" style="font-size: 10.440366972477pt;" aria-label="wroclaw (10 items)">wroclaw</a></li>
</ul>
</div>
</aside><aside id="linkcat-2" class="widget widget_links"><h3 class="widget-title">Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://ajfowler.wordpress.com/">Alecia Fowler</a></li>
<li><a href="http://littlesvr.ca/masters/">Andrew Smith</a></li>
<li><a href="http://littlecomputerscientist.wordpress.com/" title="Another one of Greg&#8217;s Grad Students">Aran at Grad School (Aran Donohue)</a></li>
<li><a href="http://florianshkurti.wordpress.com" rel="friend co-worker" title="I worked with Florian over the summer of 2009">Bumblebee (Florian Shkurti)</a></li>
<li><a href="http://www.chipx86.com/blog/" title="Christian Hammond is a developer at VMWare, and one of the core developers of Review Board.">ChipLog (Christian Hammond)</a></li>
<li><a href="http://blog.codekills.net/" rel="friend colleague" title="David was one of my partners for CSC301">Code Kills (David Wolever)</a></li>
<li><a href="http://david.navi.cx" title="David Trowbridge is a developer at VMWare, and one of the core developers of Review Board">David&#039;s Bloggy Journal (David Trowbridge)</a></li>
<li><a href="http://emilyderr.wordpress.com/" rel="friend met co-resident spouse muse crush date sweetheart" title="Emily&#8217;s musings in blog form" target="_blank">Em J</a></li>
<li><a href="http://sastraxi.wordpress.com/" title="Cameron and I worked near each other for the summer of 2009.  A totally awesome guy.">Ex Graphica (Cameron Gorrie)</a></li>
<li><a href="http://hyfen.net/" rel="friend colleague" title="Andrew worked with me on the Capstone project &#8211; RoR ninja, photographer, and more.">Hyfen.net (Andrew Louis)</a></li>
<li><a href="http://jhayne.wordpress.com/" rel="friend colleague" title="Geofrey was my partner on the Capstone project, first semester 2008-2009. We rocked that course.">Idiosyncratic/routine (Geofrey Flores)</a></li>
<li><a href="http://www.isaacezer.com" rel="friend colleague" title="I worked with Isaac in my Computer Interfaces class.  He&#8217;s an excellent jazz pianist too.">Isaac Ezer</a></li>
<li><a href="http://www.jerboaa.org/" rel="friend met co-worker colleague" title="Severin worked with me on The MarkUs Project.">Jerboaa.org (Severin Gehwolf)</a></li>
<li><a href="http://www.mjalali.com/blog/" rel="friend met co-worker colleague" title="I worked with Mohammad on figuring out Skype port signatures on a networks course">Mohammad Jalali</a></li>
<li><a href="http://half-brick.blogspot.com/" rel="friend met" title="Ayden Sherritt is a friend from highschool">Put it in a sock and hit things with it&#8230; (Ayden Sherritt)</a></li>
<li><a href="http://taraclark.ca/" rel="acquaintance met co-worker colleague" title="Tara worked with me on the MarkUs Project">Tara Clark</a></li>
<li><a href="http://www.third-bit.com" rel="contact" title="My Professor for CSC301 and Capstone course">Third Bit (Greg Wilson)</a></li>
<li><a href="http://zuzelvp47uoft.wordpress.com" rel="friend met co-worker colleague">Zuzel Vera Pacheco</a></li>

	</ul>
</aside>
<aside id="linkcat-205" class="widget widget_links"><h3 class="widget-title">Projects</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.markusproject.org" title="The Rails based open source CS student marking tool that I&#8217;ve been working on&#8230;">MarkUs Project</a></li>
<li><a href="http://www.reviewboard.org" title="I worked on Review Board as part of the Google Summer of Code 2010">Review Board</a></li>

	</ul>
</aside>
<aside id="linkcat-1207" class="widget widget_links"><h3 class="widget-title">Theater</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.artsexy.ca/">Buddies in Bad Times Theatre</a></li>
<li><a href="http://www.factorytheatre.ca/">Factory Theatre</a></li>
<li><a href="http://www.passemuraille.on.ca/">Passe-Muraille Theatre</a></li>
<li><a href="http://www.tarragontheatre.com/">Tarragon Theatre</a></li>
<li><a href="http://www.uc.utoronto.ca/content/view/340/2083/" title="UofT&#8217;s best kept secret" target="_top">The University College Drama Program</a></li>

	</ul>
</aside>
<aside id="linkcat-143" class="widget widget_links"><h3 class="widget-title">Web Development</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.alistapart.com/" title="Excellent articles on how to build beautiful, readable, accessible websites">A List Apart</a></li>

	</ul>
</aside>
<aside id="archives-3" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
				<li><a href='https://mikeconley.ca/blog/2019/03/'>March 2019</a></li>
	<li><a href='https://mikeconley.ca/blog/2019/02/'>February 2019</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/09/'>September 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/07/'>July 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/05/'>May 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/04/'>April 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/03/'>March 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/02/'>February 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2018/01/'>January 2018</a></li>
	<li><a href='https://mikeconley.ca/blog/2017/08/'>August 2017</a></li>
	<li><a href='https://mikeconley.ca/blog/2017/05/'>May 2017</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/10/'>October 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/07/'>July 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/06/'>June 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/05/'>May 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/04/'>April 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/03/'>March 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/02/'>February 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2015/01/'>January 2015</a></li>
	<li><a href='https://mikeconley.ca/blog/2014/08/'>August 2014</a></li>
	<li><a href='https://mikeconley.ca/blog/2014/07/'>July 2014</a></li>
	<li><a href='https://mikeconley.ca/blog/2014/06/'>June 2014</a></li>
	<li><a href='https://mikeconley.ca/blog/2014/05/'>May 2014</a></li>
	<li><a href='https://mikeconley.ca/blog/2014/04/'>April 2014</a></li>
	<li><a href='https://mikeconley.ca/blog/2013/12/'>December 2013</a></li>
	<li><a href='https://mikeconley.ca/blog/2013/11/'>November 2013</a></li>
	<li><a href='https://mikeconley.ca/blog/2013/06/'>June 2013</a></li>
	<li><a href='https://mikeconley.ca/blog/2013/04/'>April 2013</a></li>
	<li><a href='https://mikeconley.ca/blog/2013/03/'>March 2013</a></li>
	<li><a href='https://mikeconley.ca/blog/2013/02/'>February 2013</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/10/'>October 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/09/'>September 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/08/'>August 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/07/'>July 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/06/'>June 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/05/'>May 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2012/01/'>January 2012</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/12/'>December 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/11/'>November 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/09/'>September 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/08/'>August 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/06/'>June 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/04/'>April 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/03/'>March 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/02/'>February 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2011/01/'>January 2011</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/12/'>December 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/11/'>November 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/10/'>October 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/09/'>September 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/08/'>August 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/07/'>July 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/06/'>June 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/05/'>May 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/04/'>April 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/03/'>March 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/02/'>February 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2010/01/'>January 2010</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/12/'>December 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/11/'>November 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/10/'>October 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/09/'>September 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/08/'>August 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/07/'>July 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/06/'>June 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/05/'>May 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/04/'>April 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/03/'>March 2009</a></li>
	<li><a href='https://mikeconley.ca/blog/2009/02/'>February 2009</a></li>
		</ul>
			</aside>		</div><!-- #secondary -->
		</div><!-- #main .wrapper -->
	<footer id="colophon" role="contentinfo">
		<div class="site-info">
									<a href="https://wordpress.org/" class="imprint" title="Semantic Personal Publishing Platform">
				Proudly powered by WordPress			</a>
		</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

		<!-- Start of StatCounter Code -->
		<script>var sc_project=6280193;var sc_security="be7fa734";var sc_invisible=1;var scJsHost=(("https:"==document.location.protocol)?"https://secure.":"http://www.");</script>
		
<script type="text/javascript" src="https://secure.statcounter.com/counter/counter.js" async></script>		<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/6280193/0/be7fa734/1/" alt="web analytics"/></a></div></noscript>
		<!-- End of StatCounter Code -->
			<div style="display:none">
	</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://mikeconley.ca/blog/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201910'></script>
<script src="https://mikeconley.ca/blog/wp-content/plugins/shashin/public/display/jquery.imagesloaded.min.js,qver==3.4.11+trunk8.js,qver==3.4.11.pagespeed.jc.cjlAZotGex.js"></script><script>eval(mod_pagespeed_aLOlMNIJeu);</script>
<script>eval(mod_pagespeed_gcKb6ZBecK);</script>
<script type='text/javascript'>//<![CDATA[
var shashinJs={"ajaxUrl":"https:\/\/mikeconley.ca\/blog\/wp-admin\/admin-ajax.php","imageDisplayer":"fancybox","thumbnailDisplay":"rounded","fancyboxDir":"https:\/\/mikeconley.ca\/blog\/wp-content\/plugins\/shashin\/public\/display\/fancybox\/","fancyboxCyclic":"0","fancyboxVideoWidth":"560","fancyboxVideoHeight":"340","fancyboxTransition":"fade","fancyboxInterval":null};
//]]></script>
<script src="https://mikeconley.ca/blog/wp-content,_plugins,_shashin,_public,_display,_shashin.js,qver==3.4.11+wp-content,_themes,_twentytwelve,_js,_navigation.js,qver==20140711+wp-includes,_js,_wp-embed.min.js,qver==5.1+wp-content,_plugins,_jetpack,__inc,_build,_spin.min.js,qver==1.3+wp-content,_plugins,_jetpack,__inc,_build,_jquery.spin.min.js,qver==1.3.pagespeed.jc.9tEzkEfnws.js"></script><script>eval(mod_pagespeed_8SbT0A81oP);</script>
<script>eval(mod_pagespeed_QrjmPXbFaE);</script>
<script>eval(mod_pagespeed_G3dkl9eAYm);</script>
<script>eval(mod_pagespeed_QXavFJxN0U);</script>
<script>eval(mod_pagespeed_rjoYruVU4c);</script>
<script type='text/javascript'>//<![CDATA[
var jetpackCarouselStrings={"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/mikeconley.ca\/blog\/wp-admin\/admin-ajax.php","nonce":"7ae172c460","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/mikeconley.ca\/blog\/wp-login.php?redirect_to=https%3A%2F%2Fmikeconley.ca%2Fblog%2F2019%2F03%2F08%2Ffirefox-front-end-performance-update-14%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
//]]></script>
<script type='text/javascript' src='https://mikeconley.ca/blog/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js,qver=20190102.pagespeed.jm.r8W4Li_-uk.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201910.js' async='async' defer='defer'></script>
<script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:7.0',blog:'6522868',post:'3002',tz:'-5',srv:'mikeconley.ca'}]);_stq.push(['clickTrackerInit','6522868','3002']);</script>
</body>
</html>
